Введение

 Top Next

Тепловычислитель ВКТ-7 обладает широкими возможностями для дистанционного сбора информации о потреблении тепла, горячей и холодной воды.

С целью подключения к ВКТ-7 внешних устройств (ВУ) для съема информации (принтер, компьютер или накопительный пульт) и объединения в сеть, вычислитель комплектуется адаптером интерфейса.

В вычислителях с аппаратными версиями АВ=1.1 и АВ=2.1 имеется встроенный интерфейс RS232.

Начиная с аппаратной версии АВ=3.1, вычислитель комплектуется сменными адаптерами интерфейсов RS-232 и RS-485.

Примечание: Применение адаптера интерфейса RS-485 возможно для программной версии (ПВ) не ниже 1.9.

Адаптер интерфейса устанавливается в основание вычислителя.


Adapter RS232

Интерфейс RS232

 Top Previous Next

В штатном исполнении тепловычислитель ВКТ-7 (начиная с аппаратной версии прибора 3.1) комплектуется модулем интерфейса RS-232 для связи с компьютером, накопительными пультами НП-3 и НП-4, модемом, принтером.

Допускается объединение вычислителей в сеть по интерфейсу RS-232 (не более трех приборов) в соответствии со схемами, приведенными в Руководстве по эксплуатации. При работе в сети у каждого вычислителя имеется индивидуальный сетевой номер, по которому компьютер обращается к вычислителю.

Расстояние от вычислителя до ВУ должна быть не более 100 метров при скорости 1200 бит/с.

Примечание В аппаратной версии ниже 3.1 интерфейс RS-232 встроен и замене не подлежит!

Интерфейс имеет следующие характеристики:

· Скорость обмена 1,2; 2,4; 4,8; 9,6 и 19,2 кбит/с;
· Количество бит данных 8
· Количество стоповых бит 2
· Контроль четности нет
· Управление потоком нет

Выходные каскады интерфейса имеют гальваническую развязку от вычислителя и питаются со стороны RS-232 внешнего устройства (ВУ): компьютер, модем, принтер и др.

С помощью интерфейса RS–232 можно объединить вычислители в микросеть (до 3-5 приборов) простым запараллеливанием одноименных сигналов адаптеров RS-232. Микросеть можно подключать к компьютеру, модему или преобразователям интерфейсов (RS-232/RS-485 или RS-232/ Ethernet).

При работе в сети у каждого вычислителя должен быть индивидуальный сетевой номер, по которому компьютер обращается к вычислителю.

Недостатком такого подключения является некоторое снижение ресурса службы встроенной батареи. Для микросети из 4 приборов снижение не превышает 10%, но для группы из 32 приборов снижение становится совершенно недопустимым.

Настройка интерфейса

Для настройки интерфейса в базе данных вычислителя необходимо ввести следующие данные:

· скорость обмена с внешним устройством (ВУ) (БД->Системн.->Интерф->СО);
· тип ВУ (БД->Системн.->Интерф->ВУ);
Примечание В приборах с версией ПО < 2.Х параметр ВУ должен быть равен 0.
· сетевой номер (БД–Системн.–Рекв.–СН).
ВНИМАНИЕ! ПРИ РАБОТЕ С ОДНИМ ПРИБОРОМ МОЖНО УСТАНАВЛИВАТЬ СЕТЕВОЙ НОМЕР 00 – ШИРОКОВЕЩАТЕЛЬНЫЙ РЕЖИМ (НЕЗАВИСИМО ОТ РЕАЛЬНО УСТАНОВЛЕННОГО НОМЕРА В ПРИБОРЕ).
ЕСЛИ В СЕТИ БОЛЕЕ ОДНОГО ПРИБОРА, ТО У КАЖДОГО ДОЛЖЕН БЫТЬ ЗАДАН УНИКАЛЬНЫЙ СЕТЕВОЙ НОМЕР.
ЗАПРАШИВАТЬ ИНФОРМАЦИЮ, ЗАДАВАЯ НОМЕР 00 ПРИ ДВУХ И БОЛЕЕ ПРИБОРАХ, КАТЕГОРИЧЕСКИ ЗАПРЕЩЕНО!


Прямое подключение через RS232

Прямое подключение, интерфейс RS232

Настройки программы VKT7Easy2:

Тип соединения - прямое.

Тип интерфейса - RS232

Особенности 1. Максимальное число вычислителей, подключаемых к компьютеру – до 5;
2. Дальность связи до 100 м при скорости 1200 бит/с

Схема соединительного кабеля 1


Прямое подключение через USB

Данные в базе узлов учета:

Тип соединения - прямое.

Тип интерфейса - RS232

Схема соединительного кабеля 1

Для связи с вычислителем через интерфейс USB применяется адаптер интерфейса

После установки на компьютер драйвера алаптер в операционной системе определяется как виртуальный Com-порт.


Прямое подключение через преобразователь RS232/RS485

Для увеличения дальности связи можно применить преобразователи интерфейса RS232/RS485. К преобразователю допускается подключение микросети из 3-х ВКТ-7 по интерфейсу RS232.

Блоки питания 9-12V, подключаемые на выход вычислителя (контакты 7, 8), предназначены для питания выходных цепей адаптера интерфейса RS232. Допускается использование одного блока питания на все вычислители.

Настройки программы VKT7Easy2: Тип соединения - прямое;

Тип интерфейса - RS232.

Особенности 1. Число вычислителей, подключаемых к преобразователю – до 3;
2. Необходимо наличие блоков питания выходных каскадов вычислителя;
3 Дальность связи до 1 км.

Преобразователь интерфейса RS-232/RS-485 на стороне компьютера может быть подключен непосредственно к Com-порту компьютера или через удлинитель (кабель 3).

В качестве преобразователя интерфейса RS-232/RS-485 можно использовать преобразователь I-7520.

Схема соединительного кабеля 2.1

Схема соединительного кабеля 3


Прямое подключение через Ethernet

Вычислитель ВКТ-7 можно подключать к сети Ethernet через преобразователь интерфейса RS232/Ethernet.. К преобразователю допускается подключение микросети из 3-х ВКТ-7 по интерфейсу RS232.

Настройки программы VKT7Easy2: Тип соединения - IP network(UDP) или IP network(TCP)

Тип интерфейса - RS232

Особенности 1. Максимальное число вычислителей, подключаемых к преобразователю – до 5;

Подключение вычислителей к преобразователю интерфейса выполняется кабелем 2.2 или кабелем 3 (в зависимости от исполнения выходного разъема преобразователя).

Схема соединительного кабеля 2.2

Схема соединительного кабеля 3

В качестве преобразователей интерфейса RS232/RS485/Ethernet можно использовать:

DE311 | 5110
Преобразователь интерфейса RS232/RS485/Ethernet DE-311 | Преобразователь интерфейса RS232/Ethernet NPort 5110

Информация о настройке преобразователя интерфейса RS232/RS485/Ethernet DE-311 и преобразователя интерфейса RS232/Ethernet NPort 5110 доступна на сайте ЗАО "НПФ ТЕПЛОКОМ" www.teplocom.spb.ru


Модемное подключение через RS232

Модемное подключение, интерфейс RS-232

Настройки программы VKT7Easy2: Тип соединения - модем

Тип интерфейса - RS232

Настройка модемов приведена в описании программы VKT7Easy2.

Особенности 1. Максимальное число вычислителей, подключаемых к модему – до 3.

Схема соединительного кабеля 4


Модемное подключение по каналу GSM через RS-232

Модемное подключение по радиоканалу, интерфейс RS-232

Настройки программы VKT7Easy2: Тип соединения - модем

Тип интерфейса - RS232

Особенности работы и настройка GSM-модемов приведена в описании программы VKT7Easy2.

Особенности 1. Максимальное число вычислителей, подключаемых к модему – до 3.

Схема соединительного кабеля 4


RS485

Интерфейс RS-485

Универсальный адаптер RS485/RS232

Адаптер интерфейса RS-485 устанавливается в корпус вычислителя, начиная с аппаратной версии 3.1 и программной версии 1.9.

Универсальный адаптер позволяет осуществлять обмен информацией с вычислителем как по интерфейсу RS232, так и по интерфейсу RS485.

Интерфейс RS232 подключается стандартным образом через разъем DB9M.

Интерфейс RS485 подключается через клеммники (под винт), расположенные на плате адаптера.

Приоритетом обладает интерфейс RS232. Переключение между интерфейсами происходит автоматически при подаче сигнала RTS на контакты 7 и 8 разъема DB9M (сигнал постоянного уровня с напряжением +6,5...12В) от компьютера или накопительного пульта.

Тип применяемого интерфейса отображается с помощью светодиодных индикаторов (зеленый – интерфейс RS485, красный – интерфейс RS232).

Примечание. При отключенном блоке питания связь возможна ТОЛЬКО по интерфейсу RS-232. При этом индикация (красный светодиод) отсутствует.

Интерфейс RS-485 предназначен для объединения вычислителей в сеть и для связи с ВУ на больших расстояниях (до 1,2 км) при наличии преобразователя интерфейса RS485/RS232 на стороне внешнего устройства.

Дополнительно адаптер интерфейса выполняет следующие функции:

· Расширение диапазона адресов (максимальное количество приборов, объединяемых в сеть составляет 24000);
· Экономия ресурса батареи вычислителя за счет исключения обработки запросов от компьютера к другим приборам, находящимся в сети.

Питание адаптера осуществляется от внешнего источника напряжением 9…18 В при токе не менее 50 мА. Выход адаптера имеет гальваническую развязку от вычислителя.

Интерфейс RS-485 имеет следующие характеристики:

· Скорость обмена 1,2; 2,4; 4,8; 9,6 и 19,2 кбит/с;
· Количество бит данных 8;
· Количество стартовых бит 1
· Количество стоповых бит 1
· Контроль четности нет
· Управление потоком нет

При работе по интерфейсу RS-485 существует два режима адресации вычислителей:

· Стандартный режим адресации. Адрес вычислителя однобайтный, равный сетевому номеру (СН) вычислителя (максимальное число вычислителей в сети 240);
· Расширенный режим адресации. Адрес вычислителя двухбайтный. Для адресации вычислителя наряду с параметром СН используется дополнительный байт адреса (параметр РА) (максимальное число вычислителей в сети 24000).
Примечание Все вычислители, входящие в состав сети должны иметь одинаковый режим адресации.

Настройка интерфейса

Для работы с вычислителем по интерфейсу RS-485 необходимо настроить как вычислитель, так и адаптер интерфейса.

Для настройки вычислителя необходимо ввести следующие данные:

· Скорость обмена с ВУ (БД->Системн.->Интерф->СО);
· Тип ВУ (БД->Системн.->Интерф->ВУ). ВУ=0.
· Сетевой номер вычислителя (БД->Системн.->Рекв.->СН).

При настройке адаптера в память адаптера записываются скорость обмена и сетевей адрес вычислителя. Дополнительно задается режим адресации (стандартный или расширенный) с помощью установки джампера J2.

Настройка адаптера выполняется в меню "RS-485" вычислителя при разрешенном доступе к изменению настроечных параметров в соответствии с инструкцией, приведенной в Руководстве по эксплуатации ВКТ-7, Приложение Д.

Внимание. При любом изменении параметров интерфейса вычислителя (СО и СН) настройку адаптера интерфейса RS-485 следует выполнять всегда !


Прямое подключение через RS485

Прямое подключение через интерфейс RS-485

Встроенный интерфейс RS-485 предназначен для объединения большого количества вычислителей в сеть и для связи с компьютером на больших расстояниях (до 1 км).

В отличии от объединения вычислителей в сеть по интерфейсу RS232, количество приборов, находящихся в сети не влияет на ресурс батареи. Экономия ресурса батареи вычислителя достигается за счет исключения обработки запросов от компьютера к другим приборам, находящимся в сети.

При большом количестве вычислителей в сети на каждые 32 прибора необходимо устанавливать повторитель интерфейса RS485.

Настройки программы VKT7Easy2: Тип соединения - прямое

Тип интерфейса - RS485 (однобайтный или двухбайтный)

Особенности 1. Число вычислителей в сети:
- до 240 - однобайтный режим адресации;
- до 24000 - двухбайтный режим адресации.
2. На каждые 32 вычислителя необходим повторитель интерфейса I-7510;
3. Дальность связи до 1 км.

Схема соединительного кабеля 3

Схема соединительного кабеля 5


Подключение через Ethernet

Прямое подключение через Ethernet

Вычислитель ВКТ-7 можно подключать к сети Ethernet через преобразователь интерфейса RS485/Ethernet..

Применение интерфейса RS485 позволяет подключать к преобразователю большое количество вычислителей.

Настройки программы VKT7Easy2: Тип соединения - IP network(UDP) или IP network(TCP)

Тип интерфейса - RS485 (однобайтный или двухбайтный)

Особенности 1. Число вычислителей в сети:
- до 240 - однобайтный режим адресации;
- до 24000 - двухбайтный режим адресации.
2. На каждые 32 вычислителя необходим повторитель интерфейса I-7510;
3. Дальность связи до 1 км.

Схема соединительного кабеля 7

В качестве преобразователей интерфейса RS232/RS485/Ethernet можно использовать:

Преобразователь интерфейса RS232/RS485/Ethernet DE-311

Информация о настройке преобразователя интерфейса RS232/RS485/Ethernet DE-311 и преобразователя интерфейса RS232/Ethernet NPort 5110 доступна на сайте ЗАО "НПФ ТЕПЛОКОМ" www.teplocom.spb.ru.


Модемное подключение через RS485

Модемное подключение через интерфейс RS-485

Применение интерфейса RS485 позволяет подключать к одному модему большое количество вычислителей.

Настройки программы VKT7Easy2: Тип соединения - модем

Тип интерфейса - RS485 (однобайтный или двухбайтный)

Особенности 1. Число вычислителей в сети:
- до 240 - однобайтный режим адресации;
- до 24000 - двухбайтный режим адресации.
2. На каждые 32 вычислителя необходим повторитель интерфейса I-7510;
3. Дальность связи до 1 км.

Схема соединительного кабеля 4

Схема соединительного кабеля 5

Схема соединительного кабеля 6


Кабель1

Схема соединительного кабеля 1


Кабель2.1

Схема соединительного кабеля 2.1


Кабель 2.2

Схема соединительного кабеля 2.2


Кабель 3

Схема соединительного кабеля 3

Kabel3


Кабель 4

Схема соединительного кабеля 4

Для модема с разъемом DB9F

Для модема с разъемом DB25F


Кабель 5

Схема соединительного кабеля 5

Kabel5


Кабель 6

Схема соединительного кабеля 6

Kabel6


Кабель 7

Схема соединительного кабеля 7

Kabel7